If you press 'nav' and get 'pairing device' or something similar and it seems that the icons do not bring up the correct function then the screen will need to be calibrated.  Please follow the below guide to calibrate. 


If you have additional questions or this does not resolve the issue please contact support at support@oemautopartsco.com


2013-2015 Vehicles


•Press and hold the EJECT and TUNE>> (try seek >> if tune doesn't work) buttons for approximately 5-7 seconds to bring up the diagnostics menu

•Press on “EXIT DIAGNOSTICS” button, this should take you to another screen with “GPS INFO” showing as an option, press this which should then bring you to the calibration screen, you should see a white screen with some instructions at the top, follow the instructions to calibrate the screen. 

•Once done you can press anywhere on the white screen to exit and bring up the menu options again. Now they will be correct so you can select the “exit diagnostics” to get back to the home screen.  


2016 Vehicles


•Press and hold the EJECT and TUNE>> (try seek >> if tune doesn't work) buttons for approximately 5-7 seconds to bring up the diagnostics menu (you may have to press in the bottom right corner of the screen to get the diagnostic menu to come up). 

•Press on “EXIT DIAGNOSTICS” button, this should take you to another screen with “GPS INFO” showing as an option, press this which should then bring you to the calibration screen, you should see a white screen with some instructions at the top, follow the instructions to calibrate the screen. 

•Once done you can press anywhere on the white screen to exit and bring up the menu options again. Now they will be correct so you can select the “exit diagnostics” to get back to the home screen.